Tag Archives: Atari

Atari 2600 Complete

Finally picked up the Atari 2600 again.  I found someone selling a unit with 100 games for $100 in town.  I managed to score it for $75 but it only actually had 60 games..  Still turned out to be 40(ish) games I did not have before. and Sadly that Atari did not work.  (Discussed with seller and we agree’d it wasnt an issue because the games were what I was after, but hey.  another to sort out right…)

however of course I want to be able to PLAY these games… I’m tired of emulators.  I took the WIP unit out of the box, re opened it and decided to finish it.  this whole thing really should have been like an hour project one afternoon, not sure why I shelved it.  But I wired the transister boost I built previously, gave it power, a game and turned it on.   wow… whats that nasty hum… oh wait, theres a short for sure!….

20 minutes and a ton of tests for shorts/etc later I discovered when I made the original circuit, I put the transistor in backwards… on top of that I for some reason put the ground on the video in and the video in to VCC.  not smart.

oh well.  disassembled that bit.  reversed the in and out lines so the transistor was correct, and tested again.

and Voila!  things are running.  Before looking at the photos, I KNOW I need to work on my photo skills and my phone is NOT a suitable camera.  I’ve previously liked the details of the mod I installed and how it works, so feel free to go look at that post here

if you have any questions or just want details, please feel free to reach out to me.  I can create a schematic and wiring diagram for anyone that isn’t satisfied with the link

And finally a horrible video of it working

Atari 2600 recovery

So, this weekend I decided it was time to take my dead Atari 2600 off the shelf.  now it wasn’t scrap ready yet. it booted.. occasionally, but the when and why were magic.  So Saturday evening while my friend played GTA-V on the xboxone and drank bear I sat at my bench and probed away.  power fine… clock, fine…interesting…. things all seem good.  are the chips working…. yup.  oscilloscope shows the clock pins firing in time, good clean power… hrm.  well maybe something from the cart to the chips.  nope all good.  well I went about probing the board for well over 2 hours, and could find NO reason what-so-ever that we were not getting an RF signal.

At this point (around 2am) my friend is done playing and has taken back several beer.  He’s tired and not drunk, but definitely mentally slowed some.  Well he asks, “Did ya check the RF?” “OF COURSE I EXCLAIM”.  I know I did… it was checked when I first pulled this all apart..  well it’s late and he’s had a few.  Time to take him home and pack it in myself.

Next day I’m having coffee with my Uncle Dave as we do every Sunday to keep up on the family/etc and talk Electronics and I mention that I’ve resurrected this project.  He suggests a few things to check so we do..  are we getting video data from the chips….  well well well… it sure LOOKS like we are on the scope, but we have no way to “decode” this analog signal on my computer (likely because I’m not smart enough to do that).  Ok, we can hook the Audio to the scope an Analog Discovery 2 and have the scope output the sound.  Well what we got sounded a WHOLE lot like the Atari 2600 Morse coding a “let me die in peace”.  Well well.. that tells us its doing SOMETHING….  lets find an easy way to feed the signal to the TV.  Turns out there is a super simple circuit that crops the analog signal for composite output which i found here.  and of course I have the parts in my supply.  Oh wait.  I dont have any IC Leg clip connectors… but I have the parts… So Dave shows off his mastery of Soldering and quickly makes a couple Jumper style connects.  we get it all wired up (Figure 1), I’m crossing my fingers, I’m positive Dave is looking around for an extinguisher and we throw the switch.  it’s ugly… its messy…  but wait.. theres SOMETHING on the screen….  and it made an agressive BLIP noise.  (Figure 2).  Ok.  its something… its dirty but its there.. this is good.  Was it a fluke, was it decided to be nice and start this time…. Power cycle.  still there… again, again, again.   at least 5x as I stare in disbelief… OMG It’s working… Well Well Well.  Now I owe my friend a sorry… I’d buy him beer but i bought what he was drinking already so we’re gonna call it square.

ok, now for the meat.


Figure 1

Figure 2

 

Anyways folks, Thats my entry for this week.  Hope to see you next week.

Information & Sources:

Analog Filter (Composite Mod for Atari 2600)
Atari Field Service Manual